ユーザ用ツール

サイト用ツール


サイドバー

目次

ホーム










.

knowledge:multicast-pim-sm-static


Top#ネットワークの基礎知識に戻る

PIM-SM(静的RP)で、マルチキャストルーティング

Sparseモード(PIM-SMなど)とは

[Sender] ---- [Router1 = RP] ----- WAN ----- [Router2] ------ [Receiver]
            ファーストホップルータ           ラストホップルーター
            RPにRouter2の情報が登録される。
  • レシーバからの参加要求(Join)を待ち、必要なレシーバーのみにデータを送信するモードです。
  • SparseモードのマルチキャストルーティングプロトコルにはPIM-SM、CBTがあります。一般的にはPIM-SMが使用されています。
  • WAN環境を想定
  • Denseモードは負荷が高いので、LANでも、Sparseモードが使われることもあります。
  • Explicit Joinモデル : ルータはレシーバがいるインターフェースを把握して必要なインターフェースのみにパケットをルーティング
  • ディストリビューションツリーは、送信元ツリーと共有ツリーの組み合わせ

静的RP

マルチキャストルーティングを行うすべてのルーターにRP(中心となる機器)のアドレスを静的に設定する方法


PIM-SM(静的RP)の設定

マルチキャストルーティングを行うすべてのルーターで、に同じように設定します。

Ciscoで、PIM-SM(静的RP)

(1)INとOUT両方のインターフェースで、マルチキャストルーティングを有効化

マルチキャストルーティングを行うすべてのルーターで、IPマルチキャストルーティングを有効化します

test(config)# ip multicast-routing distributed

distributedは最近の機種では必要だが、機種によってはない。

PIM-SMを有効化するのは、INとOUTの両方必要です。
IGMPを有効化するのは、クライアント側のみで大丈夫です。

[Receiver] -----VLAN 20 --- [ SW ] ----VLAN 10 ---- [Sender]

SWの設定では、
・VLAN 20とVLAN 10 のインターフェースで、PIM-SMを有効化する必要がある
・VLAN 20のインターフェースでIGMP有効する


(2)インタフェースでPIM-SMを有効化

マルチキャストルーティングを行うすべてのインターフェースで、PIM-SMとIGMP Querier機能を有効にします。
物理のインターフェースではなく、VLANインターフェースだけでも大丈夫です。
PIMを有効化すれば自動的にIGMPが有効になります。

test(config)# interface vlan10,vlan20,vlan30
test(config-if)# ip pim sparse-mode


(3)ランデブーポイント(RP)を静的に設定

マルチキャストルーティングを行うすべてのルーターで、ランデブーポイント(RP:中心となる機器)を静的に設定します。
ランデブーポイントとして動作させるルーター(ここでは192.168.10.1)にも、そうでないルーターにも同じように行います。

test(config)# ip pim rp-address 192.168.10.1


Ciscoで、PIM-SMの確認

show ip igmp groups
show ip igmp groups vrf VRFXXX
レシーバから受信したIGMPレポートの情報を確認
マルチキャストグループにJoinしているかの確認
※マルチキャストを使っている時のみ確認可能
※L2スイッチでも表示される
show ip pim interface
show ip pim interface vrf VRFXXX
PIMが有効になっているインタフェースを確認
show ip pim neighbor
show ip pim neighbor vrf VRFXXX
PIMネイバーを確認
show ip rpf RPFインタフェースの情報を確認
show ip pim rp mapping
show ip pim rp
show ip pim rp vrf VRFXXXX
RPの情報を確認
show ip mroute
show ip mroute vrf VRFXXX
ディストリビューションツリー(マルチキャストルーティングテーブル)を確認
※マルチキャストを使っている時のみ確認可能
Debug
debug ip mrouting マルチキャストルーティングテーブルの追加・変更・削除をデバッグ
debug ip mpacket 受信したマルチキャストパケットの中身をデバッグ
debug ip pim PIMの動作をデバッグ




Juniper(Junos)で、PIM-SM(静的RP)の設定

IGMPの設定

set protocols igmp interface ge-0/0/0

# 異なるサブネットからのIGMPメッセージを受け取る
# (loopbackなどのロジカルアドレスで、/32のサブネットマスクを使用する際に必須の設定)
set protocols igmp interface ge-0/0/0 promiscus-mode

PIM Sparseモードの設定

set protocols pim interface all mode sparse

RPの設定

#RP以外の場合
set protocols pim rp static address x.x.x.x

#RP自身の場合
set protocols pim rp local address x.x.x.x


Junosで、PIM-SMの確認

show igmp interface IGMPが動作しているインターフェースを表示
show igmp group ジョインしているIGMPグループを表示
※マルチキャストを使っている時のみ確認可能
show igmp statistics IGMPに関する統計情報を表示
show pim interfaces PIMが設定されているインターフェースを表示
show pim join PIMグループを表示
※マルチキャストを使っている時のみ確認可能
show pim join extensive ※マルチキャストを使っている時のみ確認可能
show pim neighbors PIMネイバーを表示
show pim rps PIM RPを表示
show multicast route
show multicast route detail
show multicast route extensive
マルチキャストルーティングテーブルを表示
show multicast statistics




PIM-SM(静的RP)の応用設定

複数のランデプーポイントを利用する例

マルチキャストIPアドレスごとにACLを作成します。

ip pim  rp-address 192.168.1.1   ACL_Test1
ip pim  rp-address 192.168.2.2   ACL_Test2

ip access-list standard ACL_Test1
  permit 239.x.x.x 0.0.0.255
ip access-list standard ACL_Test2
  permit 239.y.y.y 0.0.0.255
  permit 239.z.z.z 0.0.0.255


VRFを使う例

ip pim vrf to-test1  rp-address x.x.x.1   ACL_Test1


DR(Designated Router=代表ルーター)による冗長化設計

  • 各サブネットにおいて、実際にマルチキャストパケットの転送を担当するルーター。
  • PIM-SMでは、マルチキャストクライアントが存在するIPサブネットごとにDRが必要です。
  • 同一LAN上に複数のPIM-SMルータが存在する場合,マルチキャスト中継の代表ルータ(DR)を一つ決めます。
    • そのインタフェース上でいちばん大きなDR Priority値(DR優先度)を持つルータがDRとなります。
    • DR Priority値が同じ場合は,いちばん大きなIPアドレスを持つルータがDRになります。
  • 同一サブネット上のPIMルーターは定期的にHelloパケットを送信して互いの状態を監視しており、DRがダウンした場合は次点のルーターがDRになります。
  • フォルトのDRプライオリティは 1 です。

Cisco

Ciscoのプライオリティ確認
R1# show ip pim neighbor
PIM Neighbor Table
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
10.10.10.1        Ethernet0/0              02:19:41/00:01:38 v2    1 / DR B S
Ciscoのプライオリティ変更
(config)# interface XXXX
(config-if)# ip pim dr-priority 10
Juniperでプライオリティを確認
> show pim neighbors detail

Instance: PIM.master
Interface: ge-0/0/0.0
Address: 192.168.195.37, IPv4, PIM v2, Mode: Sparse
Hello Option Holdtime: 65535 seconds
Hello Option DR Priority: 5
Hello Option LAN Prune Delay: delay 500 ms override 2000 ms
Join Suppression supported
Rx Join: Group Source Timeout
225.1.1.1 192.168.195.78 0
225.1.1.1 0
(abbr)
HSRP Aware PIM

HSRPによって、プライオリティーを変更する

interface ethernet 0/0
 ip address 10.0.0.2 255.255.255.0
 standby 1 ip 192.0.2.99
 standby 1 timers 5 15
 standby 1 priority 120
 standby 1 name HSRP1
 !
!

interface ethernet 0/0 
 ip address 10.0.0.2 255.255.255.0
 ip pim redundancy HSRP1 dr-priority 60
 !
!

IP Multicast: PIM Configuration Guide, Cisco IOS XE Everest 16.9.x

参考

マルチキャストの受信だけを行いたい場合の受信側の設定方法

  • IGMPは送受信で許可(受信側から送信側に送る必要があるため)
  • UDPは、受信のみ許可
  • それ以外は全て拒否
Reciever      <--------------     Sender

INPUT
  ACCEPT igmp 
  ACCEPT udp
  DROP   all


OUTPUT
  ACCEPT  igmp
  DROP    all


構内配線で他社と接続する場合のマルチキャストの冗長構成

参考




knowledge


knowledge/multicast-pim-sm-static.txt · 最終更新: 2022/05/08 23:38 by kurihara

ページ用ツール