ユーザ用ツール

サイト用ツール


device:switch:index.html


Top#スイッチに戻る

現場で必要な「スイッチ」の基礎知識

スイッチ概要

  • L2スイッチは、複数のポートがあり、サーバやPCなどの機器を接続する。
  • L3スイッチは、ルーティングを行う
  • VLANを使うことにより、複数のネットワークセグメントを持てる
  • スイッチの1GBのポートは、上り1GBと下り1GBの最大2GBの処理能力がある。
  • スイッチのカスケード接続は、無制限だが、若干の遅延が発生する。(1台 0.008msec程度)

ルータとスイッチの違い

  • スイッチはNATができない(最近はできる機器もある)
  • スイッチは、ポート数が多い
  • スイッチはVLANを使える
  • ルータはソフトウェア的に処理するので、ルーティングエントリ数が多い。スイッチはハードウェアで処理するので、ルーティングエントリ数に制限がある。

用語

用語 説明
MACアドレス 物理アドレス
ARP プロトコル
Address Resolution Protocol
IPアドレスから対応するMACアドレスを得るためのプロトコル
MACアドレステーブル MACと宛先ポートの一覧
L2SWもL3SWも持っている
ARPテーブル IPとMACの対応表
L3SWが持っている。L2SWは持っていない。


スイッチの種類

L2SW ブリッジングを行う。
・「MACアドレステーブル」を持っている。
L3SW ルーティングを行う。
・「MACアドレステーブル」を持っている。
・「ARPテーブル」を持っている。
・「ルーティングテーブル」を持っている。


スイッチの機能

L2(データリンク層)の機能

VLAN
(Virtual LAN)
スパニングツリー
(STP)
(Spanning Tree Protocol)
リンクアグリゲーション
イーサチャネル
SNMP

L3(ネットワーク層)の機能

ルーティング 別のセグメントにアクセスできるようにする。
ルーティングテーブルにより、パケットの適切な転送先を決定する機能
VRRP Virtual Router Redundancy Protocol
複数のL3SWをグループ化して、1つのIPアドレスを持たせ、冗長化するためのプロトコル
IPフォワーディング スイッチのポートからポートへIPパケットを転送する機能
パケットフィルタリング パケットの宛先IPやポート番号をチェックし、不正なパケットを止める機能
Ciscoでいうと、ACL


スイッチポートとルーテッドポートの違い

スイッチポート

  • L2ポート
  • スイッチのデフォルトのポート
  • VLANを割り与えられる。
  • IPをアサインする時は、VLANインターフェースを作成してから。
interface GigabitEthernet1/0/1
  description To_XXXXX
  switchport access vlan 11
  switchport mode access

interface GigabitEthernet1/0/2
  description To_XXXXX
  switchport trunk encapsulation dot1q
  switchport trunk allowed vlan 10,11,12
  switchport mode trunk

interface Vlan10
  ip address 192.168.10.10

ルーテッドポート

  • L3ポート
  • インターフェースに、IPを振れる
  • Ciscoの場合、インターフェースにno switchportとする
interface GigabitEthernet1/0/5
 description To_XXXXX
  no switchport
  ip address xx.xx.xx.xx 255.255.255.0


L2接続とL3接続の違い

L2で機器間を同じネットワークセグメントとして接続する場合

  • 機器同士に同じVLANを指定して、接続します。
  • 物理図で機器とタグ情報を確認できます。
  • 論理図にはL2スイッチは省略されます。

L3で機器間を別々のネットワークセグメントとして接続する場合

  • 機器間の別のセグメント間はルーティングで接続します。
  • 論理図で、ネットワークセグメントが確認できます。
  • 物理図ですとルーティング、ネットワークセグメントがどのようになっているかはわからないです。


スタックのデメリット

Stack構成を組むスイッチではすべてのスタックメンバーでバージョンを合わせるため、ファームウェアにバグがあった場合に両系に影響が出てしまいます。バグが通信に大きく影響があるレベルであれば、完全に停止してしまう可能性もあります。
ルーティングを片寄して迂回を行い、片系ずつバージョンアップするなど問題発生時の経路迂回が難しく、完全な冗長性を担保することが出来ません。
スタックケーブルの半刺しやスタックモジュール障害時にリブートを繰り返してバタついてしまうケースも存在します。
Stack機能は非常に便利ですが、運用まで視野に入れる場合はファームウェアのアップデート手順や障害時の経路迂回など、どの程度の通信断時間が許容されるかを考慮した導入検討が必要です。

Stack構成のメリットとデメリット - ネットワークエンジニアの備忘録








Top#スイッチに戻る


device/switch/index.html.txt · 最終更新: 2019/06/04 23:46 by kurihara

ページ用ツール