ユーザ用ツール

サイト用ツール


サイドバー

ネットワークを勉強したいエンジニアにオススメの本

目次

device:switch:vlanrouting.html


Top#スイッチに戻る

L3スイッチで、VLAN間ルーティング(SVIかルーテッドポート)

VLAN間ルーティングとは

L3スイッチ内で、複数のVLAN同士(Vlan10とvlan20)をルーティングして、接続すること


方法1:SVI(Switch Virtual Interface)を利用する方法

VLAN間ルーティングでは、この方法が利用されます。

L3スイッチには、内部ルータがあります。
VLANインタフェースを作成し、IPアドレスを付けることで、
内部ルータと接続できるようになり、ルーティングしてくれます。


方法2:物理ポートをルーテッドポートとして利用する方法

L3スイッチには、内部ルータがあります。
物理ポートにVLAN設定をしないで、ルーティング用のルーテッドポートとし、
物理インターフェイスにIPを振ることで、内部ルータと接続します。

一般的にはVLAN間ルーティングのためではなく、ルータと接続する時の設定です。


設定

Cisco SVIの方法

■IPルーティングの設定
Switch# conf t
Switch# ip routing              ← ルーティング機能を有効にする


■ポートにVLANの設定
Switch(config)# interface FastEthernet 0/0
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 10

Switch(config)# interface FastEthernet 0/1
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 20


■SVIの設定
Switch(config)# interface vlan 10
Switch(config-if)# ip address 10.1.1.1 255.255.255.0
Switch(config-if)# no shutdown

Switch(config)# interface vlan 20
Switch(config-if)# ip address 10.1.2.1 255.255.255.0
Switch(config-if)# no shutdown


■確認
Switch# show ip route


Cisco機器で、ルーテッドポートにする方法

Cisco Switchの場合、インターフェースに、no switchportとすることで、ルーテッドポートになり、IPをアサインできます。

Switch# conf t
Switch# ip routing              ← ルーティング機能を有効にする

Switch(config)# interface FastEthernet 0/0
Switch(config-if)# no switchport               <- ルーテッドポートにする。
Switch(config-if)# ip address 10.1.1.1 255.255.255.0

Switch(config)# interface FastEthernet 0/1
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.1.2.1 255.255.255.0






Top#スイッチに戻る


device/switch/vlanrouting.html.txt · 最終更新: 2019/06/04 23:51 by kurihara

ページ用ツール