ユーザ用ツール

サイト用ツール


サイドバー

ネットワークを勉強したいエンジニアにオススメの本

目次

vendor:cisco:catalyst-qos


ホーム#ベンダー機器

Cisco Catalyst SwitchのQoS設定

QoSの処理

分類 パケットにQoSラベルを対応付けて、分類する
マーキング トラフィックのフレーム、パケットのヘッダーに書き込む
ポリシング(帯域制御) 特定条件に適用したトラフィックをどうするか決める
スケジューリング どのような順番でフレームやパケットを送信するかを決める
キューイング バッファー内にあるパケットを優先順位に応じて送信




MQCベースとポートベースのQoS

MQC(Modular QoS CLI)

MQCを利用できる機種

  • シャーシ型Catalystの最近のIOS
  • Catalyst3560や3750より後に出荷されたCatalyst3850等ではMQCベースのQoSのみサポートしています。
  • Catalyst3750もMQCに対応しています。


QoS設定方法

class-mapやpolicy-map等でどのような条件ではどのように動作する等を定義し、
service-policyコマンドでインターフェースに適用します。

各ポリシーマップでいくつかのクラスマップを呼び出し、
各クラスマップに対して帯域幅、バッファサイズ、および優先度を定義することができます。
最後のクラスを「デフォルト」として定義し、
このクラスに特定の帯域幅を割り当て、
このクラスに分類されなかったすべてのトラフィックを割り当てることをお奨めします。

priority コマンドは、トラフィックに対する帯域保証を設定します。
このオプションは、音声やビデオなど遅延の影響を受けるトラフィックに対して有効です。
bandwidth コマンドは、そのトラフィッククラス用に帯域幅を予約し、
queue limit は、そのトラフィッククラスについてキューに保持できる最大パケット数を指定します。
帯域幅をパーセントで指定すると、使用可能な帯域幅はインタフェースの帯域幅に基づいて計算されるか、
interface で設定された「bandwidth」に対するパーセントとして計算されます。

「Day One:IOSエンジニア向けJunos QoS」




ポートベースのQoS設定

ポートベースのQoSを設定できる機種

  • 1世代前のCatalyst2960、3560、3750シリーズ


QoS設定方法

インターフェースに直接どのような動作をするのかを設定します。
mls qos インターフェイス ベースのコマンドを使用

ポートがアクセス ポートまたはレイヤ 3 ポート mls qos trust dscp コマンド
フレームには dot1q タグまたは ISL タグが含まれていないため、mls qos trust cos コマンドを使用できません。
ポートがトランク ポートmls qos trust cos コマンドまたは mls qos trust dscp コマンドのいずれか




クラス分け / マーキング

クラス分けは、優先度を決定します。
マーキングは、優先度をパケットに書き込みます。


優先度

CoS Class of Service
レイヤ 2 フレーム ヘッダーの QoS ラベル(3bit)
Trunk接続しているのであればCoS
DSCP Differentiated Services Code Point
IPパケットに優先度を付加するために使用します。
レイヤ 3 IP ヘッダーのQoS ラベル(3bit)
IPP
IP Precedence
IP プレシデンス
レイヤ 3 IP ヘッダーのQoS ラベル(6bit)
DSCPの方が詳細な設定ができるため、DSCPが使われ環境が増えています
DSCP
PHB
(Per Hop Behavior)
DSCP値
(2進数)
(優先度 破棄レベル)
DSCP値
(10進数)
備考
Default 000 000 0 ベストエフォートで転送
CS
( Class Selector )
CS0 000 000 0
CS1 001 000 8
CS2 010 000 16
CS3 011 000 24
CS4 100 000 32
CS5 101 000 40
CS6 110 000 48
CS7 111 000 56
AF
(Assured Forwarding)
AF11 001 010 10
AF12 001 100 12
AF13 001 110 14
AF21 010 010 18
AF22 010 100 20
AF23 010 110 22
AF31 011 010 26
AF32 011 100 28
AF33 011 110 30
AF41 100 010 34
AF42 100 100 36
AF43 100 110 38
EF
(Expedited Forwarding)
101 110 46 最優先処理する音声トラフィックに通常割り当てる。
IP Precedence

DSCPの方が詳細な設定ができるため、DSCPが使われ環境が増えています

Precedence 0 routine
Precedence 1 priority
Precedence 2 immediate
Precedence 3 flash
Precedence 4 flash-override
Precedence 5 critical ユーザが指定できる値で最も優先度
音声などで利用される
Precedence 6 internet ルーティングパケットや、keepalive などのルータの
制御パケット用に予約されている
Precedence 7 network
設定例(COS)
mls qos

interface GigabitEthernet1/0/1
  switchport access vlan 10
  switchport mode access
  mls qos cos 5
  mls qos overrride
設定例

既にマーキングされたDSCPの値を信用する

interface GigabitEthernet1/0/1
  switchport access vlan 100
  switchport mode access
  mls qos trust dscp
設定例(ACL利用)

https://www.unix-power.net/networking/catalyst-2960-3560-3750-qos

access-list 100 permit ip any any

class-map match-all QoS
  match access-group 100

policy-map QoS
  class QoS
  set ip precedence 5

interface GigabitEthernet1/0/1
  switchport access vlan 100
  switchport mode access
  service-policy input QoS
ポートベースのQoS設定例

Cisco Catalyst 3750 の QoS 設定例 - Cisco

ポートがアクセス ポートまたはレイヤ 3 ポートの場合、mls qos trust dscp コマンドを設定する必要があります。 アクセス ポートまたはレイヤ 3 ポートからのフレームには dot1q タグまたは ISL タグが含まれていないため、mls qos trust cos コマンドを使用できません。 CoS ビットがあるのは、dot1q フレーム内または ISL フレーム内のみです。

interface GigabitEthernet1/0/1
 description **** Layer 3 Port ****
 no switchport
 ip address 192.168.10.1 255.255.255.0
 mls qos trust dscp
end
interface GigabitEthernet1/0/2
 description **** Access Port ****
 switchport access vlan 10
 switchport mode access
 mls qos trust dscp
end
ポートベースのQoS設定例

ポートがトランク ポートの場合、mls qos trust cos コマンドまたは mls qos trust dscp コマンドのいずれかを設定できます。 ポートが DSCP を信頼するように設定されている場合、dscp-cos マッピング テーブルを使用して CoS 値が計算されます。 同様に、ポートが CoS を信頼するように設定されている場合、cos-dscp マッピング テーブルを使用して DSCP 値が計算されます。

interface GigabitEthernet1/0/3
description **** Trunk Port ****
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk native vlan 5
switchport trunk allowed vlan 5,10,20,30,40,50
mls qos trust cos
end
interface GigabitEthernet1/0/12
 description **** Cisco IP Phone  ****
 switchport access vlan 10
 switchport mode access
 switchport voice vlan 20
 mls qos trust cos
 spanning-tree portfast
end


スケジューリング

2960/3560/3750のスケジューリング

SRR ( Shaped Round Robin ) 方式で、SharedモードとShapedモードがあります。

設定例

https://www.unix-power.net/networking/catalyst-2960-3560-3750-qos

特定Gi1/0/24から入ってくる特定パケット ( 送信元が192.168.0.0/24 ) をキュー1に配置し、
Gi1/0/1から出力する際に優先制御させる設定例となります。
Gi1/0/2は192.168.0.0/24からのパケットを出力しますが、こちらは優先制御はかけずにshapedを解除する設定

mls qos

class-map match-all vlan192
  match access-group name vlan192

policy-map vlan192-priority
  class vlan192
  set dscp ef


interface GigabitEthernet1/0/1
  priority-queue out

interface GigabitEthernet1/0/2
  srr-queue bandwidth shape 0 0 0 0
 
interface GigabitEthernet1/0/24
  service-policy input vlan192-priority


ip access-list extended vlan192
  permit ip 192.168.0.0 0.0.255.255 any


帯域制御 ( ポリシング )

2960/3560/3750の帯域制御

設定例

https://www.unix-power.net/networking/catalyst-2960-3560-3750-qos

送信元が192.168.0.0/16に限定して帯域を10Mに指定する設定例です。
police 10000000 1000の部分が帯域を指定している部分であり、1000はバーストサイズを意味します。

mls qos

class-map match-all vlan192
  match access-group name vlan192

policy-map vlan192-police
  class vlan192
  police 10000000 1000 exceed-action drop     # 10,000,000=10M

interface GigabitEthernet1/0/1
  service-policy input vlan192-police

ip access-list extended vlan192
  permit ip 192.168.0.0 0.0.255.255 any


設定例(VLANに設定)

https://www.unix-power.net/networking/catalyst-2960-3560-3750-qos

mls qos

class-map match-all vlan192
  match access-group name vlan192

policy-map vlan192-police
  class vlan192
  police 10000000 1000 exceed-action drop

interface GigabitEthernet1/0/1
  mls qos vlan-based

interface Vlan10
  ip address 192.168.0.1 255.255.0.0
  service-policy input vlan192-police

ip access-list extended vlan192
   permit ip 192.168.0.0 0.0.255.255 any


MQCベースのQoS設定例

例1

access-list 1  permit xx.xx.xx.xx 0.0.0.255

class-map match-all voice
  match access-group 1            #access-list 1

policy-map voice-protect
  class voice
    set ip dscp 40

interface GigabitEthernet 0/1
  service-policy input voice-protect

ip access-list extended acl-ope
  permit ip any  10.20.20.0 0.255.255.255

class-map match-all class-ope
  match access-group acl-ope

policy-map policy-ope
  class class-ope
    set ip precedence 5

interface FastEthernet 0/1
  service-policy output  class-ope

例2

policy-map policy1
  class class1
    bandwidth 1000
    queue-limit 20
  class class2
    bandwidth 2000

例3

Ciscoルータ QoS

access-list 100 permit tcp 172.16.0.0 0.15.255.255 any eq 80
access-list 101 permit tcp 192.168.0.0 0.0.255.255 any eq 80

class-map match-all QoS1
  match access-group 100
class-map match-all QoS2
  match access-group 101

policy-map QoS
  class QoS1
    bandwidth 10000   !トラフィックが輻輳した際に、10Mbpsの帯域が保証
  class QoS2
    bandwidth 20000   !トラフィックが輻輳した際に、20Mbpsの帯域が保証

interface Ethernet0/1
  service-policy output QoS


設定内容の確認やパケット数の確認
# show policy-map interface fa0/0



参考


vendor/cisco/catalyst-qos.txt · 最終更新: 2019/09/06 11:43 by kurihara

ページ用ツール