ユーザ用ツール

サイト用ツール


サイドバー

ネットワークを勉強したいエンジニアにオススメの本

目次

ホーム









.

device:router:routing:eigrp.html


Top#ルータに戻る

EIGRPで動的ルーティング

概要


Cisco 設定例

 192.168.0.0/24      192.168.1.0/24      192.168.2.0/24      192.168.3.0/24 
----------------[R1]----------------[R2]----------------[R3]-----------------
             .1      .1          .2      .2          .3      .3
R1(config)# router eigrp 1
R1(config-router)# network 192.168.0.1  0.0.0.255   <-  自分のIP
R1(config-router)# network 192.168.1.1  0.0.0.255   <-  自分のIP
R2(config)# router eigrp 1
R2(config-router)# network 192.168.1.2  0.0.0.255   <-  自分のIP
R2(config-router)# network 192.168.2.2  0.0.0.255   <-  自分のIP
R3(config)# router eigrp 1
R3(config-router)# network 192.168.2.3  0.0.0.255   <-  自分のIP
R3(config-router)# network 192.168.3.3  0.0.0.255   <-  自分のIP


passive-interfaceで、ルーティングアップデートを停止

接続先がPCやサーバなど動的ルーティングを持っていない場合に、passive-interfaceを指定することにより、ルーティングアップデートを停止します。
このpassive-interfaceコマンドは、EIGRPだけではなく、RIPの送信やOSPFのHelloパケット送信を停止します。

router eigrp 10
passive-interface default      #基本的に全てのインターフェースで、ルーティングアップデートを停止
no pasive-interface Vlan100    #Vlan100は、、ルーティングアップデートをする


redistributeで、他のプロトコルで学習した経路情報を、EIGRPへ再配布

router eigrp 10

#OSPFで学習した経路情報を、EIGRPへ再配布
#シードメトリック(帯域幅/遅延/信頼性/負荷/MTU)
redistribute ospf 10 metric 1000000 1 255 1 1500

#スタティックルーティングの経路を、EIGRPへ再配布
#シードメトリック(帯域幅/遅延/信頼性/負荷/MTU)
redistribute static metric 100000 1 255 1 1500
redistribute connected metric 100000 1 255 1 1500

#EIGRP 200で学習した経路情報を、EIGRP 10で再配布
redistribute eigrp 200


distribute-listで、ルーティングアップデート設定

ルーティングアップデートで、特定のルートを送信(out)しないようにしたり、特定のルートを受信(in)しないようにすることができます。

prefixで自身のNWを宣言しつつ、別のルーティングプロトコルでルーティング

EIGRPによる宛先のティーティングではなく、
スタティックルートで指定した宛先にルーティングしたい場合、prefixで設定する必要があります。

EIGRPのnetwork 192.168.1.0 0.0.0.255を指定してしまうと、
EIGRPのルーティングになってしまい、スタティックルートで設定した宛先にルーティングしてくれなくなります。

ip route 192.168.1.0 255.255.255.0 172.16.0.1
ip route 192.168.2.0 255.255.255.0 172.16.0.1

ip prefix-list EIGRP-STATIC  permit 192.168.1.0/24
ip prefix-list EIGRP-STATIC  permit 192.168.2.0/24

router eigrp 1
  redistribute static metric 1000000 1 255 1 1500
  distribute-list prefix EIGRP-STATIC out static
  network 10.50.1.0  0.0.0.255
| NW1             |
| 192.168.1.0/24  | ---- [Router1] --- |  NW2  |
| 192.168.2.0/24  |

NW1のネットワーク情報を  NW2に配布
NW2の機器は、192.168.1.0/24, 192.168.2.0/24なら、Router1宛てに送る


acl

#「10.50.1.0/24 と 10.50.2.0/24」のルートのみ送信(out)を許可(permit)
access-list 10 permit 10.50.1.0 0.0.0.255
access-list 10 permit 10.50.2.0 0.0.0.255

router eigrp 1
distribute-list 10 out GigabitEthernet0/0








Top#ルータに戻る


device/router/routing/eigrp.html.txt · 最終更新: 2020/05/12 12:55 by kurihara

ページ用ツール