ユーザ用ツール

サイト用ツール


サイドバー

目次

ホーム










.

knowledge:multicast-routing


Top#ネットワークの基礎知識に戻る

金融取引でも使われるUDPのマルチキャストルーティングの設定

マルチキャストルーティングプロトコルのモード

マルチキャストルーティングプロトコルにより、Receiverの存在するインターフェースを通知します。

Denseモード(PIM-DMなど)

  • LAN環境を想定
  • 負荷が高い
  • Flood & Pruneモデル:すべてのインターフェースにパケットをルーティングする。
  • ディストリビューションツリーは、送信元ツリー
  • Denseモードのマルチキャストルーティングプロトコルには、DVMRPやMOSPFやPIM-DMがあります。一般的にはPIM-DMが使用されます。
  • マルチキャスト配送経路の決定にユニキャストの経路表を流用します
  • 受信インターフェース以外のすべてのインターフェースにパケットを転送します。

IPマルチキャストルーティングを有効化

test(config)# ip multicast-routing

マルチキャストルーティングを行うすべてのインターフェースで、PIM-DMとIGMP Querier機能を有効にします

test(config)# interface vlan10,vlan20,vlan30
test(config-if)# ip pim dense-mode
test(config-if)# ip igmp 


Sparseモード(PIM-SMなど)

[Sender] --> [Router1 = RP] ----WAN---> [Router2] ---> [Receiver]

RPにRouter2の情報が登録される。
  • WAN環境を想定
  • Denseモードは負荷が高いので、LANでも、Sparseモードが使われることもあります。
  • Explicit Joinモデル : ルータはレシーバがいるインターフェースを把握して必要なインターフェースのみにパケットをルーティング
  • ディストリビューションツリーは、送信元ツリーと共有ツリーの組み合わせ
  • SparseモードのマルチキャストルーティングプロトコルにはPIM-SM、CBTがあります。一般的にはPIM-SMが使用されています。

PIM-SMでは、次の役割を持つルーター

DR
Designated Router
代表ルーター
各サブネットに1台
サブネット内に複数のPIMルーターが存在する場合、インターフェースに設定されたDR優先度の値がもっとも大きなルーターがDRとなります。
RP
Rendezvous Point
ランデブーポイント
各マルチキャストグループに1台
RPの候補(C-RP)が複数存在する場合、RP優先度値のもっとも小さいルーターがRPに選出されます。
BSR
Bootstrap Router
ブートストラップルーター
PIM-SMネットワークに1台
PIM-SMネットワークにおいて、RP候補とマルチキャストグループの一覧、および、各グループのRP一覧を管理・広告するルーター。
複数のBSR候補(C-BSR)が存在するときは、BSR優先度値のもっとも大きいルーターがBSRに選出されます。
動的RP ブートストラップメカニズム(BSRがRPの情報を広告する)を利用して動的に決める方法
静的RP 各ルーターにRPのアドレスを静的に設定する方法


PIM-DMの設定

基本的にすべてのルーターで同じ設定となります。

IPマルチキャストルーティングを有効化

test(config)# ip multicast-routing

マルチキャストルーティングを行うすべてのインターフェースで、PIM-SMとIGMP Querier機能を有効

test(config)# interface vlan10,vlan20,vlan30
test(config-if)# ip pim dense-mode
test(config-if)# ip igmp


PIM-SM動的RPの設定

ランデブーポイント(RP)の設定

IPマルチキャストルーティングを有効化

test(config)# ip multicast-routing

マルチキャストルーティングを行うすべてのインターフェースで、PIM-SMとIGMP Querier機能を有効

test(config)# interface vlan10,vlan20,vlan30
test(config-if)# ip pim sparse-mode
test(config-if)# ip igmp

ランデブーポイントとして動作するよう設定

test(config)# ip pim rp-candidate vlan10   <- 広告時のアドレスとしては、vlan10のIPアドレス

PIM-SM使用時、ランデブーポイントがダウンしていてもマルチキャストルーティングが行われることがありますが、この状態が続くとCPU 使用率が上昇します。
ランデブーポイントを設定するときはループバックインターフェースのアドレスを使用してダウンしないようにするか、
ランデブーポイントを複数用意して冗長化してください。


ブートストラップルーター(BSR)の設定

IPマルチキャストルーティングを有効化

test(config)# ip multicast-routing

ブートストラップルーターとして動作するよう設定

test(config)# ip pim bsr-candidate vlan10 <- 広告時のアドレスとしては、vlan10のIPアドレス


その他のルーター(非RP)の設定

IPマルチキャストルーティングを有効化

test(config)# ip multicast-routing

マルチキャストルーティングを行うすべてのインターフェースで、PIM-SMとIGMP Querier機能を有効

test(config)# interface vlan10,vlan20,vlan30
test(config-if)# ip pim sparse-mode
test(config-if)# ip igmp


PIM-SM静的RPの設定

すべてのルーターに対し、特定のルーターがランデブーポイント(RP)であるということを静的に設定します。

IPマルチキャストルーティングを有効化

test(config)# ip multicast-routing

マルチキャストルーティングを行うすべてのインターフェースで、PIM-SMとIGMP Querier機能を有効

test(config)# interface vlan10,vlan20,vlan30
test(config-if)# ip pim sparse-mode
test(config-if)# ip igmp

ランデブーポイント(RP)を静的に設定します。
ランデブーポイントとして動作させるルーター(ここでは192.168.10.1)にも、そうでないルーターにも同じように行います。

test(config)# ip pim rp-address 192.168.10.1


Ciscoのマルチキャスト設定

マルチキャストルーティングの確認

> show ip mroute

マルチキャストルーティングの有効化

# ip multicast-routing  distributed

distributedは最近の機種では必要だが、機種によってはない。

インターフェースの設定

PIM-SMモードの設定

RPを設定する必要がある。

Switch# configure terminal
Switch(config)# ip multicast-routing distributed
Switch(config)# interface range vlan 11 - 13
Switch(config-if-range)# ip pim sparse-dense-mode
Switch(config-if-range)# exit
Switch(config)# ip pim rp-address 172.16.2.1    #RP(ランデブーポイント:中心となる機器)のIPアドレス

PIM-DMモードの設定
RPを設定せずにマルチキャストを実現するPIM-DMモード
既にユニキャストルーティングの設定が行われている前提

Switch# configure terminal
Switch(config)# ip multicast-routing distributed
Switch(config)# interface range vlan 11 - 13
Switch(config-if-range)# ip pim sparse-dense-mode
Switch(config-if-range)# exit

R1(config)# interface GigabitEthernet0/0
R1(config-if)#ip pim dense-mode

TIPS

複数のランデプーポイントを利用する例

ip pim  rp-address x.x.x.1   ACL_Test1
ip pim  rp-address y.y.y.y   ACL_Test2

ip access-list standard ACL_Test1
  permit x.x.x.x 0.0.0.255
ip access-list standard ACL_Test2
  permit y.y.y.y 0.0.0.255
  permit z.z.z.z 0.0.0.255


VRFを使う例

ip pim vrf to-test1  rp-address x.x.x.1   ACL_Test1




Junosのマルチキャスト設定

Junosでマルチキャストルーティングテーブルを表示

> show multicast route extensive




Linuxで、マルチキャストの動作確認

自分の参加しているマルチキャストを表示

netstat -g

tcpdumpでマルチキャストパケットの確認

tcpdump -i any igmp   <-  IGMPの確認

tcpdump -i any -n udp and not port 161   <-  UDP 161(SNMP)以外のUDP全て











参考


knowledge/multicast-routing.txt · 最終更新: 2020/08/30 01:37 by kurihara

ページ用ツール